What does the sample name ZZTo4eJJ mean?

What does the sample name ZZTo4eJJ mean?

Hi! The naming convention for the simulated data is documented in this page: CERN Open Data Portal
From the name, this looks like a process with two Z bosons decaying to four electrons, with, in addition, two jets present in the final state. If you need more details, could you provide the link to the record that you are referring to?

Best, Kati for the CMS open data team

Thank you for your clarification. My doubt was whether it’s an associated production of two jets along with two Z’s that are decaying to 4e or three Z’s were produced where two of them decay into 4e and the 3rd one to two jets. The link to the dataset is as follows:

In regards to the same MC dataset, another issue I faced was when I was trying to run the executable, I encountered the following error:

----- Begin Fatal Exception 25-Feb-2022 07:13:44 CET-----------------------
An exception of category 'StdException' occurred while
   [0] Constructing the EventProcessor
   [1] Constructing ESSource: class=PoolDBESSource label='GlobalTag'
Exception Message:
A std::exception was thrown.
Connection on "sqlite_file:/opt/cms-opendata-conddb/START53_LV6A1_MC_stripped.db" cannot be established ( CORAL : "ConnectionPool::getSessionFromNewConnection" from "CORAL/Services/ConnectionService" )
----- End Fatal Exception -------------------------------------------------

I have used the global tag recommended for analysis. I am pasting the code for my configuration file below.

import FWCore.ParameterSet.Config as cms
import FWCore.Utilities.FileUtils as FileUtils
import FWCore.PythonUtilities.LumiList as LumiList
import FWCore.ParameterSet.Types as CfgTypes

import os
import sys

relBase = os.environ['CMSSW_BASE']

process = cms.Process("ZZTo4eqq")

process.MessageLogger.cerr.threshold = "WARNING"
process.MessageLogger.cerr.INFO = cms.untracked.PSet(limit=cms.untracked.int32(-1))
process.options = cms.untracked.PSet(wantSummary=cms.untracked.bool(True))

process.maxEvents = cms.untracked.PSet( input = cms.untracked.int32(100) )

#Load needed configuration

#Loading datasets

process.source = cms.Source("PoolSource",fileNames = cms.untracked.vstring(sourceFile))

#For access to conditions database
process.GlobalTag.connect = cms.string('sqlite_file:/opt/cms-opendata-conddb/START53_LV6A1_MC_stripped.db')
process.GlobalTag.globaltag = 'START53_LV6A1::All'

process.zzto4eqq = cms.EDAnalyzer('ZZTo4eqq',
InputCollection = cms.InputTag("gsfElectrons"))

process.TFileService = cms.Service("TFileService",fileName = cms.string('Output.root'))
process.p = cms.Path(process.zzto4eqq)

Thanks for the details! Which environment are you using for running the job? The error message points to the condition data file which was made available in /opt/cms-opendata-conddb/START53_LV6A1_MC_stripped.db in the container that was used in the tutorial (i.e. cmsopendata/cmssw_5_3_32_vnc or cmsopendata/cmssw_5_3_32.

If you are using another container (e.g. cmsopendata/cmssw_5_3_32-slc6_amd64_gcc472), comment out the line starting with process.GlobalTag.connect....

If you are using the VM image, do as instructed under 2012 Monte Carlo in CERN Open Data Portal condition data guide.

Hope this helps!

Best, Kati

The container I am using is cmsopendata/cmssw_5_3_32 which was used in the tutorial. I commented out the line you mentioned after I realised there is no local condition database available. But then I obtained this error.

----- Begin Fatal Exception 25-Feb-2022 16:02:05 CET-----------------------
An exception of category 'TrivialFileCatalog' occurred while
   [0] Constructing the EventProcessor
   [1] Constructing input source of type PoolSource
Exception Message:
TrivialFileCatalog::connect: Unable to open trivial file catalog /cvmfs/cms.cern.ch/SITECONF/local/PhEDEx/storage.xml 
----- End Fatal Exception -------------------------------------------------

OK, thanks. That container should have the local condition data file available. Is /opt/cms-opendata-conddb empty (or does that folder exist) in your case?

Yes, it exists. I ran the command below to find it out.

[ -d "/opt/cms-opendata-conddb" ] && echo "Directory exists."

However, I don’t know how to locate the path to this directory. I tried using the commands find and locate , but it did not return any output.

Just to make sure, is there anything in there (i.e what does ls -l /opt/cms-opendata-conddb give)?


total 96
drwxr-xr-x 2 cmsinst cmsinst  4096 Jul  6  2021 FT53_V21A_AN6_FULL
-rw-r--r-- 1 cmsinst cmsinst 45056 Jul  5  2021 FT53_V21A_AN6_FULL_data_stripped.db
drwxr-xr-x 2 cmsinst cmsinst  4096 Jul  6  2021 START53_V27
-rw-r--r-- 1 cmsinst cmsinst 45056 Jul  5  2021 START53_V27_MC_stripped.db

But from where do I download the database with the global tag START53_LV6A1?

OK, now I see. I do not think we have built a container with the local db’s for the 2011 data/MC. I’ll check. The tutorial container had those for 2012 data/MC. It should however work, if you comment out the connect line (process.GlobalTag.connect ...) and keep the one for the tag. In that case it will access the condition db remotely.

I see. But I was getting an error even then. I shall then wait to see if you are able to find a link to the docker image for the 2011 data/MC. Thank you.

I do not think we have it available right now. We can build it if needed. Meanwhile, would you try with the standard 5_3_32 container cmsopendata/cmssw_5_3_32-slc6_amd64_gcc472?

Hi @kati , I was trying to download cmsopendata/cmssw_5_3_32-slc6_amd64_gcc472 , but ended up getting this error.

Docker: Error response from daemon: pull access denied for cmsopendata/cmssw_5_3_32-slc6_amd64_gcc472,
the repository does not exist or may require 'docker login': denied: requested access to the resource is denied.

I have already checked the query on this error on the forum; I have gone through the pre-exercises of Docker in the CMS Open workshop that mentions this error; I have also tried downloading it via the alternate image location. However, I was able to pull docker images of other CMSSW releases. Can you please tell me why this error only occurs for cmsopendata/cmssw_5_3_32-slc6_amd64_gcc472 ?

Hi, I have figured out the issue. The error was not caused by the Global tag. The way I had given the path to sourcefile was the problem. I have fixed it. Thank you.