Issue in opening a root file

I was working in a ROOT container and I am able to open all root files except one which I created from the CMSSW container . Actually I was trying to open the root file using vncserver from within the CMSSW container but I was facing this issue

So I decided to copy my root file to root container but when I double click on branches nothing comes but a white screen however if i try to open some other root file . I am able to open all the branches.

Below is the screenshot for normal root file opening :

Below is the screenshot for the ROOT fie generated from CMSSW , not showing anything:


The first error message comes because you the GUI was not opened with vnc_start in the container (or there were errors).

Your screenshot shows that your myoutput.root was produced with POET. For further help, we would need to know what selections you made and what was the input file.

Did you check that your input file contains the objects you’ve selected for the process path?

Best, Kati
for the CMS open data team

Actually , while working in the CMSSW container somehow I forgot to give the command stop_vnc which is normally not an issue as the .vnc has a log file which stores the process I’d(PID) of the VNC running. However, this time something happened and the command cannot find that file . So , I instead deleted the mount of CMSSW container on my laptop and the container from Docker also. And then created the container and mount again and issue got resolved.
Further, I found that while giving configuration file to cmsRun executable I forgot to gave true as additional argument due to which it used some MC simulated file as the source and when opening its result in the root file nothing was opening. So I tried with CMS data file after which it worked and I was able to see all the branches with TBrowser.

Thank You so Much for replying though😊

OK, good to hear that the problem got solved.

In most cases, if stop_vnc was not done before exiting from the container, it is enough to do it again once back in the same container. And then start_vnc.

Best, Kati

1 Like