Downloading root files

Hello, I am using the CernVM2015 and CMSSW_5_3_32 and am stuck trying to complete level 4 of the Higgs-to-four-lepton analysis example using 2011-2012 data, this is because I am unable to figure out how to download the data and index files, I have tried installing cernopendata-client but from what I understand it cannot be installed due to the version of pip getting this error message Command “python egg_info” failed with error code 1 in /tmp/pip-build-o5jrZc/cernopendata-client/. I get a similar error message when trying to upgrade pip or setup tools.

Any help would be greatly appreciated.

Many thanks

Hello Maximilian!

Many thanks for your report! To be able to follow up, would you kindly specify if you use the VM available from the CERN open data portal (e.g. CMS VM Image, for 2011, 2012 and 2015 CMS open data | CERN Open Data Portal) or is CernVM2015 that you mention something different?

Thank you!

for the CMS open data team

I am using the CMS VM Image for 2015

OK, thanks!

I’ll test myself, but meanwhile, could you try in the “Outer shell” before doing the cmsenv command in the “CMS shell”? It has a more recent environment (but it will also get “downgraded” by the cmsenv command so that’s why you would need to try before it).

Note that the data files can also be read through XRootD and you do need them locally. Use the full path for the name, for example:


You can get the index files through curl and/or wget.

This said, we will follow up to make cernopendata-client work for downloads, or document any exceptions.

All the best, Kati

Thank you,

I tried running ,pip install cernopendata-client, and got the same error Command “python egg_info” failed with error code 1 in /tmp/pip-build-dJ3psG/cernopendata-client/.

I also get the same error when trying to update pip or install XRootD.

Many thanks

Max Potter

Thanks, good to know,

To go forward, please read the files through XRootD in your analysis program with the syntax indicated above or if you want to download, use, e.g.

xrdcp  root:// .

We’ll follow up on the opendata-client issues
@tiborsimko: this is when attempting to install cernopendata-client on the VM (slc6/cc7)

Best, Kati

Thank you, for your help